您的位置:首页 > 其它

杭电 —1212 大数取模

2016-07-18 16:45 211 查看


Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7152    Accepted Submission(s): 4934


Problem Description

As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.

 

Input

The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.

 

Output

For each test case, you have to ouput the result of A mod B.

 

Sample Input

2 3
12 7
152455856554521 3250

 

Sample Output

2
5
1521

 

Author

Ignatius.L

 

Source

杭电ACM省赛集训队选拔赛之热身赛

 
解题思路:这道题用的求模思路和我们平时进行的除法的套路是一样的。
先是第一个数取模,然后乘10加上后面的数接着取模,往后类推。
AC代码:

#include<stdio.h>
#include<string.h>
int main()
{
char a[1100];
int b,i;
while(scanf("%s%d",a,&b)!=EOF)
{
int len=strlen(a);
int sum=0;
for(i=0;i<len;i++)
{
sum=sum*10+a[i]-'0';
sum=sum%b;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: