您的位置:首页 > 大数据 > 人工智能

ACM--元辅音--HDOJ 1039--Easier Done Than Said?--字符串

2016-07-15 20:45 633 查看
HDOJ题目地址:传送门


Easier Done Than Said?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11702 Accepted Submission(s): 5678

Problem Description

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them
and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end


Sample Output

<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.


题目大意:这个题目主要是对字符串进行处理,具体有三个要求:1、至少存在一个元音 2、不能出现连续两个相同的字母,除了oo和ee 3、不能出现三个连续的元音,也不能出现三个连续的辅音。

#include<stdio.h>
#include<iostream>
#include<memory.h>
#include<string.h>
using namespace std;
char yuanyin[5]={ 'a', 'e', 'i', 'o','u'};
int main(){
string s;
while(cin>>s){
if(s=="end")
break;
int flag_1=0,//元音标记
flag_2=0,//辅音标记
count=0;//元音总数标记
int flag=0;
for(int i=0;i<s.size();i++){
//至少有一个元音
if(s[i]==yuanyin[0]||s[i]==yuanyin[1]||s[i]==yuanyin[2]||
s[i]==yuanyin[3]||s[i]==yuanyin[4]){
count++;
flag_1++;
flag_2=0;
}
if(flag_1>=3){
break;
}
//不能有两个连续的字母,除了e和o
if(s[i]==s[i+1]&&s[i]!='e'&&s[i]!='o'){
flag=1;
break;
}
if(!(s[i]==yuanyin[0]||s[i]==yuanyin[1]||s[i]==yuanyin[2]||
s[i]==yuanyin[3]||s[i]==yuanyin[4])){
flag_1=0;
flag_2++;
}
if(flag_2>=3){
break;
}
}
if(flag==1||count==0||flag_1>=3||flag_2>=3){
printf("<%s> is not acceptable.\n",s.c_str());
}else{
printf("<%s> is acceptable.\n",s.c_str());
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: