您的位置:首页 > Web前端

hdu 1015 Safecracker

2016-07-09 17:53 405 查看


Safecracker

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12405    Accepted Submission(s): 6397


Problem Description

=== Op tech briefing, 2002/11/02 06:42 CST === 

"The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein's secrets and
wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters,
usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing
the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, ..., Z=26). The combination is then
vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary." 

v - w^2 + x^3 - y^4 + z^5 = target 

"For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode
the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn't exist then." 

=== Op tech directive, computer division, 2002/11/02 12:30 CST === 

"Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then
at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or 'no solution'
if there is no correct combination. Use the exact format shown below."

 

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

 

Sample Output

LKEBA
YOXUZ
GHOST
no solution

 

   题目意思就是把输入的字母换成对应的数字,然后找出五个数字v、w、x、y、z满足他那个等式。且其字典序最大;

字典序最大被坑了一把。第一次我把每个数字加一起最大的输出,,样例有一个对不上。

   后来用strcmp   1Y;

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
int len,n,v,w,x,y,z,a1,a2,a3,a4,a5,flag;
bool c[16];
int b[15];
char nu[5],ni[5];
void dfs(int t){
if(t==5&&n==abs(v-w*w+x*x*x-y*y*y*y+z*z*z*z*z)) {
flag=1;
nu[0]=v+'0'+16;nu[1]=w+'0'+16;nu[2]=x+'0'+16;nu[3]=y+'0'+16;nu[4]=z+'0'+16;
ni[0]=a1+'0'+16;ni[1]=a2+'0'+16;ni[2]=a3+'0'+16;ni[3]=a4+'0'+16;ni[4]=a5+'0'+16;
if(strcmp(ni,nu)<0) {
a1=v;a2=w;a3=x;a4=y;a5=z;
}
return;
}
if(t>=5) return ;
for(int i=0;i<len;i++){
if(!c[i]){
c[i]=1;
if(t==0) {
v=b[i];dfs(t+1);c[i]=0;
}
else if(t==1) {
w=b[i];dfs(t+1);c[i]=0;
}
else if(t==2) {
x=b[i];dfs(t+1);c[i]=0;
}
else if(t==3) {
y=b[i];dfs(t+1);c[i]=0;
}
else if(t==4) {
z=b[i];dfs(t+1);c[i]=0;
}
}//printf("%d %d %d %d %d\n",v,w,x,y,z);
}
}
int main(){
char a[15];
while(~scanf("%d%s",&n,a)){
flag=0;
memset(c,0,sizeof(c));a1=a2=a3=a4=a5=0;
if(n==0&&!strcmp(a,"END")) break;
len=strlen(a);
for(int i=0;i<len;i++)
b[i]=a[i]-'0'-16;//cout<<a[i]<<" "<<b[i]<<endl;
dfs(0);
if(flag)printf("%c%c%c%c%c\n",a1+'0'+16,a2+'0'+16,a3+'0'+16,a4+'0'+16,a5+'0'+16);
else printf("no solution\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: