您的位置:首页 > 其它

HDU 1052 Tian Ji -- The Horse Racing

2016-07-12 14:55 477 查看


Tian Ji -- The Horse Racing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25936    Accepted Submission(s): 7636


Problem Description

Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from
the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you
think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's
horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find
the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too
advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

 

Input

The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers
on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.

 

Output

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

 

Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0

 

Sample Output

200
0
0
1.先用最弱的给齐王最弱的比能赢就比。2.在那最强的和齐王最强的比,能赢就比。3.如果1.2都不满足,就拿最弱的和齐王最强的比。代码:
#include<iostream>
#include<string>
#include<cctype>
#include<algorithm>
#include<cstdio>
using namespace std;

int main(){
int n,i,j;
int t[1005],q[1005];
while(~scanf("%d",&n)&&n){
int ans=0;
for(i=0;i<n;i++)
scanf("%d",&t[i]);
for(i=0;i<n;i++)
scanf("%d",&q[i]);
int head1=0,tail1=n-1;
int head2=0,tail2=n-1;
sort(t,t+n);sort(q,q+n);
while(head1<=tail1){
if(t[head1]>q[head2]){
head1++;head2++;
ans+=200;
}
else if(t[tail1]>q[tail2]){
tail1--;tail2--;
ans+=200;
}
else {
if(t[head1]>q[tail2]){
head1++;tail2--;
ans+=200;
}
else if(t[head1]==q[tail2]){
head1++;tail2--;
}
else {
head1++;tail2--;
ans-=200;
}
}
}
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: