您的位置:首页 > 大数据 > 人工智能

【杭电-oj】-1702-ACboy needs your help again!(栈和队列基础)

2016-06-30 19:03 525 查看


ACboy needs your help again!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5346    Accepted Submission(s): 2783


Problem Description

ACboy was kidnapped!! 

he miss his mother very much and is very scare now.You can't image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster's labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can't solve my problems, you will die with ACboy."

The problems of the monster is shown on the wall:

Each problem's first line is a integer N(the number of commands), and a word "FIFO" or "FILO".(you are very happy because you know "FIFO" stands for "First In First Out", and "FILO" means "First In Last Out").

and the following N lines, each line is "IN M" or "OUT", (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

 

Input

The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.

 

Output

For each command "OUT", you should output a integer depend on the word is "FIFO" or "FILO", or a word "None" if you don't have any integer.

 

Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

 

Sample Output

1
2
2
1
1
2
None
2
3

 
     本题是栈和队列的基本例题,注意相同点和不同点。

#include<cstdio>
#include<algorithm>
#include<queue>
#include<stack>
using namespace std;
int main()
{
int m;
char sty[10];
char op[10];
scanf("%d",&m);
while(m--)
{
int n;
scanf("%d %s",&n,sty);
if(sty[2]=='F')
{
queue<int> q;
while(n--)
{
scanf("%s",op);
if(op[0]=='I')
{
int t;
scanf("%d",&t);
q.push(t);
}
else
{
if(q.empty())
printf("None\n");
else
{
printf("%d\n",q.front());
q.pop();
}
}
}
}
else
{
stack<int> stk;
while(n--)
{
scanf("%s",op);
if(op[0]=='I')
{
int t;
scanf("%d",&t);
stk.push(t);
}
else
{
if(stk.empty())
printf("None\n");
else
{
printf("%d\n",stk.top());
stk.pop();
}
}
}
}
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: