您的位置:首页 > 编程语言 > PHP开发

Given a positive integer N, you should output the most right digit of N^N.

2016-06-30 11:28 706 查看

Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4


Sample Output

7
6


Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.

In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include<stdio.h>
#include<stdlib.h>
int main()
{
int n,m,i,j,a,b;
long long int sum=1;
while(~scanf("%d",&n))
{
for(i=0;i<n;i++)
{
scanf("%d",&m);
b=m%20;
if(b==0)
b=10;
a=1;
for(j=0;j<b;j++)
{
sum=a*b;
a=sum%10;
}
printf("%d\n",a);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: