您的位置:首页 > 产品设计 > UI/UE

ACM--DP--HDOJ 1005--Number Sequence

2016-06-28 21:14 423 查看
HDOJ题目地址:传送门


Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 150172 Accepted Submission(s): 36565

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0


Sample Output

2
5


题解:开始的时候用递归做超内存,后来发现 n 这个取值范围也太大了,后来看别人的,用DP,结果为48为一个

周期,这样就AC了

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<memory.h>
using namespace std;
int main(){
int a,b,n;
int arr[48];
arr[1]=1;
arr[2]=1;
while(scanf("%d%d%d",&a,&b,&n)&&a&&b&&n){
for(int i=3;i<48;i++){
arr[i]=(a*arr[i-1]+b*arr[i-2])%7;
}
printf("%d\n",arr[n%48]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: