您的位置:首页 > 编程语言 > Go语言

POJ 2262 Goldbach's Conjecture(素数)

2016-06-27 22:28 459 查看
Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 

written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 

20 = 3 + 17 = 7 + 13. 

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 

Each test case consists of one even integer n with 6 <= n < 1000000. 

Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair
where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0


Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


打一个素数表  遍历一下看看有没有相应的n-prime[i]满足visit为true 注意是<=n/2

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <string.h>
using namespace std;

const int MAX=1000050;
bool visit[MAX];
int prime[MAX];

int init_prim()
{
memset(visit, true, sizeof(visit));
int num = 0;
for (int i = 2; i <= MAX; ++i)
{
if (visit[i] == true)
{
num++;
prime[num] = i;
}
for (int j = 1; ((j <= num) && (i * prime[j] <= MAX)); ++j)
{
visit[i * prime[j]] = false;
if (i % prime[j] == 0) break;
}
}
return num;//返回质数个数
}

int main()
{
int n,c;
init_prim();
while(scanf("%d",&n)&&n)
{
c=0;
for(int i=1;prime[i]<=n/2;i++)
{
if(visit[n-prime[i]]==true)
{
printf("%d = %d + %d\n",n,prime[i],n-prime[i]);
c=1;
break;
}
}
if(c==0) printf("Goldbach's conjecture is wrong.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: