您的位置:首页 > 其它

HDU 1213 How Many Tables

2016-06-24 00:20 344 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1213

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 23102    Accepted Submission(s): 11517

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and
all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of
friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

 

Sample Output

2
4

 

Author

Ignatius.L
 

Source

杭电ACM省赛集训队选拔赛之热身赛

 

Recommend

Eddy

思路:裸的并查集,直接上代码。

附上AC代码:

#include <bits/stdc++.h>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
const int maxn = 1005;
int p[maxn];
int n, m;
vector<int> v;

int _find(int x){
return p[x]==x ? x : p[x]=_find(p[x]);
}

int main(){
#ifdef LOCAL
freopen("input.txt", "r", stdin);
freopen("output.txt", "w", stdout);
#endif
int T;
scanf("%d", &T);
while (T--){
scanf("%d%d", &n, &m);
for (int i=1; i<=n; ++i)
p[i] = i;
int a, b;
while (m--){
scanf("%d%d", &a, &b);
a = _find(a);
b = _find(b);
p[a] = b;
}
int ans = 1;
v.clear();
v.push_back(_find(1));
for (int i=2; i<=n; ++i){
int t = _find(i);
if (find(v.begin(), v.end(), t) == v.end()){
++ans;
v.push_back(t);
}
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 并查集