您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表六:有序链表的建立

2016-06-21 21:17 393 查看


数据结构实验之链表六:有序链表的建立




Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^



题目描述

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。


输入

第一行输入整数个数N;

第二行输入N个无序的整数。


输出

依次输出有序链表的结点值。


示例输入

6
33 6 22 9 44 5



示例输出

5 6 9 22 33 44



提示

不得使用数组!


来源

 


示例程序

 

view plaincopyprint如果您复制代码时出现行号,请点击左边的“view
plain”后再复制

#include <stdio.h>  

#include <stdlib.h>  

struct node  

{  

    int data;  

    struct node *next;  

}*head;  

int main()  

{  

    head=(struct node*)malloc(sizeof(struct node));  

    head->next=NULL;  

    int i,n;  

    struct node *p,*q,*t;  

    scanf("%d",&n);  

    p=(struct node*)malloc(sizeof(struct node));  

    q=(struct node*)malloc(sizeof(struct node));  

    for(i=0; i<n; i++)  

    {  

        t=(struct node*)malloc(sizeof(struct node));  

        scanf("%d",&t->data);  

        p=head->next;  

        q=head;  

        while(p!=NULL)  

        {  

            if(t->data<p->data)  

            {  

                q->next=t;  

                t->next=p;  

                break;  

            }  

            q=p;  

            p=p->next;  

        }  

        if(p==NULL)  

        {  

            q->next=t;  

            t->next=NULL;  

        }  

    }  

    p=head->next;  

    while(p!=NULL)  

    {  

        if(p->next==NULL)  

            printf("%d\n",p->data);  

        else  

            printf("%d ",p->data);  

        p=p->next;  

    }  

    return 0;  

}  

   
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: