您的位置:首页 > 产品设计 > UI/UE

solution Of 1101. Quick Sort (25)

2016-06-16 00:01 471 查看
1101. Quick Sort (25)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N = 5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;

3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;

2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;

and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5

1 3 2 4 5

Sample Output:

3

1 4 5

结题思路 :

题意要求我们找到数组中所有满足的数。

要求1:数组中的数字都是不同的;

要求2:满足条件的数要求左侧的子数列最大的值要小于当前数字,右侧的最小的值要大于当前数字。

程序步骤:

第一步、正序计算并记录数组中每个数字包括自己与之前的子数列中的最大值;

第二步、倒序计算并记录数组中每个数字包括自己与之后的子数列中的最小值;

第三部、计算满足条件的数字放入结果数组序列中,排序,输出。

具体程序(AC)如下:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
vector<int> preMax;
vector<int>nextMin;
vector<int>value;
int main(int argc, char const *argv[])
{
int num;
cin>>num;
preMax.resize(num,-1);
nextMin.resiee(num,-1);
value.resize(num,-1);
int i;
int node;
for(i=0;i<num;++i)
cin>>value[i];
int max=-1;
for(i=0;i<num;++i)
{
preMax[i]=(max<value[i]?value[i]:max)
max=preMax[i];
}
int min=0x7fffffff
for(i=num-1;i>=0;--i)
{
nextMin[i]=(min>value[i]?value[i]:min)
min=nextMin[i]
}
vector<int> result;
result.clear();
for(i=0;i<num;++i)
{
if(preMax[i]<=value[i]&&value[i]<=nextMin[i])
result.push_back(value[i]);
}
sort(result.begin(),result.end());
cout<<result.size()<<endl;
if(result.size()>0)
cout<<result[i];
for(i=1;i<result.size();++i)
cout<<" "<<result[i];
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: