您的位置:首页 > 其它

solution Of 1055. The World's Richest (25)

2016-06-22 02:04 344 查看
1055. The World’s Richest (25)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=105) - the total number of people, and K (<=103) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [-106, 106]) of a person. Finally there are K lines of queries, each contains three positive integers: M (<= 100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line “Case #X:” where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output “None”.

Sample Input:

12 4

Zoe_Bill 35 2333

Bob_Volk 24 5888

Anny_Cin 95 999999

Williams 30 -22

Cindy 76 76000

Alice 18 88888

Joe_Mike 32 3222

Michael 5 300000

Rosemary 40 5888

Dobby 24 5888

Billy 24 5888

Nobody 5 0

4 15 45

4 30 35

4 5 95

1 45 50

Sample Output:

Case #1:

Alice 18 88888

Billy 24 5888

Bob_Volk 24 5888

Dobby 24 5888

Case #2:

Joe_Mike 32 3222

Zoe_Bill 35 2333

Williams 30 -22

Case #3:

Anny_Cin 95 999999

Michael 5 300000

Alice 18 88888

Cindy 76 76000

Case #4:

None

结题思路 :

题意要求我们输出指定年龄范围的人的排序信息。

要求1:对每个人排序时实际上用的是对指针数组进行排序;

要求2:感觉可以用二分搜索来加速年龄的位置定位(虽然没有这样做)。

程序步骤:

第一步、存储个人信息,并排序;

第二步、对符合条件的个人信息进行输出,在满足搜索数量的情况下可以提前退出。

具体程序(AC)如下:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
struct node{
char name[10];
int age;
int num;
};
int cmp(node *a,node *b)
{
if(a->num!=b->num)
return a->num>b->num;
else
if(a->age!=b->age)
return a->age<b->age;
else
return strcmp(a->name,b->name)<0;
}
node rich[100005];
node* richIndex[100005];
int main()
{
int num,testN,i,j,k,count;
while(scanf("%d %d",&num,&testN)!=EOF)
{
for(i=0;i<num;++i)
{
scanf("%s %d %d",&rich[i].name,&rich[i].age,&rich[i].num);
richIndex[i]=&rich[i];
}
sort(richIndex,richIndex+num,cmp);
int queryNum,queryAge1,queryAge2;
for(i=0;i<testN;++i)
{
scanf("%d %d %d",&queryNum,&queryAge1,&queryAge2);
cout<<"Case #"<<i+1<<":"<<endl;
count=0;
for(j=0;j<num;++j)
{
if(count>=queryNum)
break;
if(richIndex[j]->age<=queryAge2&&queryAge1<=richIndex[j]->age)
{
printf("%s %d %d\n",richIndex[j]->name,richIndex[j]->age,richIndex[j]->num);
++count;
}
}
if(count==0)
printf("None\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: