您的位置:首页 > 其它

HDU 2715 Herd Sums

2016-06-12 22:37 357 查看


Herd Sums

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 841    Accepted Submission(s): 416


Problem Description

The cows in farmer John's herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N.

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up
to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5.

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10.

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem.

 

Input

* Line 1: A single integer: N

 

Output

* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N.

 

Sample Input

15

 

Sample Output

4

 

Source

USACO 2003 March Orange

 

Recommend

teddy   |   We have carefully selected several similar problems for you:  2716 2710 2709 2711 2713 

题意:判断多少种方式使连续的数字和为n

思路:等差数列求和的应用。

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int n,ans,i,j,k,l,m;
while(scanf("%d",&n)!=EOF)
{
ans=0;
for(i=1;i*i<2*n;i++)
{
if((2*n)%i==0&&(((2*n)/i-i)%2))
ans++;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: