您的位置:首页 > 其它

poj3372

2016-06-12 21:16 204 查看
Candy Distribution

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5868Accepted: 3274
Description

N children standing in circle who are numbered 1 through N clockwise are waiting their candies. Their teacher distributes the candies by in the following way:

First the teacher gives child No.1 and No.2 a candy each. Then he walks clockwise along the circle, skipping one child (child No.3) and giving the next one (child No.4) a candy. And then he goes on his walk, skipping two children (child No.5 and No.6) and giving the next one (child No.7) a candy. And so on.

Now you have to tell the teacher whether all the children will get at least one candy?

Input

The input consists of several data sets, each containing a positive integer N (2 ≤ N ≤ 1,000,000,000).

Output

For each data set the output should be either "YES" or "NO".

Sample Input

2
3
4

Sample Output

YES
NO
YES

Source

POJ Monthly--2007.09.09, ailyanlu@zsu
这是一个复杂的数学问题,但是可以通过小数据猜测出来,最后发现只要是2的幂就行,否则不行

#include<cstdio>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)==1)
{
while(n%2==0)
n/= 2;
if(n==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: