您的位置:首页 > 其它

hdu 2619 Love you Ten thousand years(数论,待解决)

2016-06-10 20:10 357 查看


Love you Ten thousand years

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 92    Accepted Submission(s): 34


Problem Description

Love you Ten thousand years------Earth's rotation is a day that is the representative of a day I love you. True love, there is no limit and no defects. Earth's revolution once a year, it is on behalf of my love you more than a year. Permanent horizon, and my
heart will never change ……

We say that integer x, 0 < x < n,(n is a odd prime number) is a LovePoint-based-on n if and only if the set { (xi mod n) | 1 <= i <= n-1 } is equal to { 1, ..., n-1 }. For example, the powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a LovePoint-based-on
7. 

Now give you a integer n >= 3(n will not exceed 231).

We say the number of LovePoint-based-on n is the number of days the earth rotating.

Your task is to calculate the number of days someone loved you.

 

Input

Each line of the input contains an integer n. Input is terminated by the end-of-file.

 

Output

For each n, print a single number that gives the number of days someone loved you.

 

Sample Input

5

 

Sample Output

2

看了网上的一份题解,对n做两次除以所有质因数乘以质因数-1即可得到答案,为什么??

完全不是夜深人静写算法里面说的找规律,后来人如果发现另外的解法或者此种解法的缘由,还望指点。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define LL long long
int vis[100];
LL get(LL n)
{
LL ans=n;
for(int i=2;i*i<=n;i++)
{
if(n%i==0)
{
ans=ans/i*(i-1);
while(n%i==0)
n/=i;
}
}
if(n>1) ans=ans/n*(n-1);
return ans;
}
int main()
{
LL m;
while(scanf("%lld",&m)!=EOF)
{
printf("%lld\n",get(get(m)));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: