您的位置:首页 > 其它

HDU 1232 畅通工程 (第一道并查集,两种方式)

2016-06-08 23:31 323 查看


畅通工程

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 44676 Accepted Submission(s): 23695



Problem Description

某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?

Input

测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。

注意:两个城市之间可以有多条道路相通,也就是说

3 3

1 2

1 2

2 1

这种输入也是合法的

当N为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最少还需要建设的道路数目。

Sample Input

4 2
1 3
4 3
3 3
1 2
1 3
2 3
5 2
1 2
3 5
999 0
0


Sample Output

1
0
2
998

HintHint
Huge input, scanf is recommended.


Source

浙大计算机研究生复试上机考试-2005年

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1232

第一道并查集


AC代码:

#include <iostream>
#include <cstring>
using namespace std;
const int maxn =1000+5;
int fa[maxn];
int Find(int x)
{
//return fa[x]==-1?x:fa[x]=Find(fa[x]);
if(fa[x]==-1)
return x;
return fa[x]=Find(fa[x]);
}
int mix(int x,int y)
{
int fx=Find(x);
int fy=Find(y);
if(fx!=fy)
{
fa[fx]=fy;
return 1;
}
return 0;
}
int main()
{
int n,m;
while(cin>>n,n)
{
cin>>m;
int ans=n-1;
memset(fa,-1,sizeof(fa));
while(m--)
{
int x,y;
cin>>x>>y;
ans-=mix(x,y);
}
cout<<ans<<endl;
}
return 0;
}




AC代码2:

#include <iostream>
#include <cstring>
using namespace std;
const int maxn = 1000+5;
int fa[maxn];
int Find(int x)
{
if(fa[x]==-1)
return x;
return fa[x]=Find(fa[x]);
//return Find(fa[x]);//OK
}
void mix(int x,int y)
{
int fx=Find(x);
int fy=Find(y);
if(fx!=fy)
fa[fx]=fy;
}
int main()
{
int n,m;
while(cin>>n,n)
{
cin>>m;
//memset(fa,-1,sizeof(-1));
for(int i=1;i<=n;i++)
fa[i]=-1;
while(m--)
{
int x,y;
cin>>x>>y;
mix(x,y);
}
int ans=0;
for(int i=1;i<=n;i++)
if(fa[i]==-1)
ans++;
cout<<ans-1<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: