您的位置:首页 > 其它

poj 2388 Who's in the Middle

2016-06-04 19:46 429 查看
Who's in the Middle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38442 Accepted: 22325
Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
Output

* Line 1: A single integer that is the median milk output.
Sample Input
5
2
4
1
3
5

Sample Output
3

Hint

INPUT DETAILS: 

Five cows with milk outputs of 1..5 

OUTPUT DETAILS: 

1 and 2 are below 3; 4 and 5 are above 3.
Source

USACO 2004 November

排好序后输出中间值;

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<string>
#include<cstring>
int s[10001];
using namespace std;

int main()
{
int n;
scanf("%d",&n);
for(int i=1;i<=n;++i)
{
scanf("%d",&s[i]);
}
sort(s+1,s+1+n);
printf("%d\n",s[n/2+1]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj