您的位置:首页 > 产品设计 > UI/UE

02-线性结构3 Pop Sequence

2016-05-31 16:31 387 查看
Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, …, NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MM is 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN (the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5

1 2 3 4 5 6 7

3 2 1 7 5 6 4

7 6 5 4 3 2 1

5 6 4 3 7 2 1

1 7 6 5 4 3 2

Sample Output:

YES

NO

NO

YES

NO

问题描述:把1-N个数依次进栈,给出出栈的结果,判断是否可能有这种出栈方式。

思路:当大的数pop出来的时候,小的数肯定已经进去了,所以模拟这一过程,若按照输入的序列不会爆栈,则这种情况是可能的,否则就不可能。

#include <iostream>
#include <stack>

using namespace std;

void input()
{
int stack_capacity, input_num, input_line;
stack<int> st;
cin >> stack_capacity;
cin >> input_num;
cin >> input_line;

int* temp = new int[input_num];
int* ifpossible = new int[input_line];

for (int i = 0; i < input_line; i++)
{
ifpossible[i] = 1;
int k = 1;
for (int j = 0; j<input_num;j++)
{
cin >> temp[j];

while (st.size() <= stack_capacity)
{
if (st.empty() || st.top() != temp[j])
{
st.push(k++);
}
else if (st.top() == temp[j])
{
st.pop();
break;
}

}
if (st.size() > stack_capacity)
{
ifpossible[i] = 0;
}

}
while (!st.empty())
st.pop();

}

for (int i = 0; i < input_line; i++)
{
if (ifpossible[i] == 0)
cout << "NO" << endl;
else
cout << "YES" << endl;
}
delete[]temp;
delete[]ifpossible;
}

int main()
{
input();

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: