您的位置:首页 > 其它

04-树6 Complete Binary Search Tree

2016-06-02 15:56 302 查看
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.

The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.

Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer NN (\le 1000≤1000). Then NN distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10

1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题目大意:构建符合完全二叉树的搜索树

思路:因为是完全二叉树,且为搜索树,所以key大小按照最后一层从左到右,依次往上排列。所以可以把输入序列从小到大排列好,从最小的key开始,把其放入在二叉树适当位置。

#include <iostream>
using namespace std;

int *b;
int j = 0;

int compare(const void * a, const void * b)
{
return *(int *)a - *(int *)b;
}

void mid_tre(int root, int N, int a[]){
if (root <= N){
mid_tre(2 * root, N, a);
b[root] = a[j++];
mid_tre(2 * root + 1, N, a);
}
}

int main(){
int N;
int i = 0;
cin >> N;
int* a = new int
;
b = new int
;
for (i = 0; i<N; i++){
cin>>a[i];
}
qsort(a, N, sizeof(int), compare);
mid_tre(1, N, a);
cout<<b[1];

for (i = 2; i <= N; i++){
cout<<' '<< b[i];
}

delete[]a;
delete[]b;

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: