您的位置:首页 > 理论基础 > 数据结构算法

数据结构上机测试2-1:单链表操作A

2016-05-30 11:10 393 查看


数据结构上机测试2-1:单链表操作A




Time Limit: 1000ms   Memory limit: 4096K  有疑问?点这里^_^



题目描述

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。


输入

第一行输入数据个数n;

第二行依次输入n个整数;

第三行输入欲删除数据m。


输出

第一行输出原始单链表的长度;

第二行依次输出原始单链表的数据;

第三行输出完成删除后的单链表长度;

第四行依次输出完成删除后的单链表数据。


示例输入

10
56 25 12 33 66 54 7 12 33 12
12



示例输出

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33


view plaincopyprint如果您复制代码时出现行号,请点击左边的“view
plain”后再复制

#include <stdio.h>  

#include <malloc.h>  

struct node  

{  

    int date;  

    struct node * next;  

};  

struct node * creat(int n)  

{  

    struct node * head,* tail,*p;  

    int i;  

    head=(struct node *)malloc(sizeof(struct node));  

    head->next=NULL;  

    tail=head;  

    for(i=1;i<=n;i++)  

    {  

        p=(struct node *)malloc(sizeof(struct node ));  

        scanf("%d",&p->date);  

        p->next=NULL;  

        tail->next=p;  

        tail=p;  

    }  

    return (head);  

}  

void del(struct node * head,int n,int m)  

{  

    struct node * p, * q;  

    int flag=0;  

    p=head;  

    while(p->next!=NULL)  

    {  

        if(p->next->date==m)  

        {  

            n=n-1;  

            q=p->next;  

            p->next=q->next;  

            free(q);  

        }  

        else p=p->next;  

    }  

    printf("%d\n",n);  

}  

void Dis_list(struct node *l)  

{  

    struct node  *r;  

    r=l;  

    while(r->next->next!=NULL)  

    {  

        printf("%d ",r->next->date);  

        r=r->next;  

    }  

    printf("%d\n",r->next->date);  

}  

int main(int argc,char** argv)  

{  

    int n,m;  

    struct node *head;  

    scanf("%d\n",&n);      

    head=creat(n);  

    scanf("%d",&m);  

    printf("%d\n",n);  

    Dis_list(head);  

    del(head,n,m);  

    Dis_list(head);  

    return 0;  

}  

   



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: