您的位置:首页 > 其它

ACM 数论 HDU 2608 0 or 1 规律!

2016-05-29 17:33 330 查看
[align=left]Problem Description[/align]
Solving problem is a interesting thing. Yifenfei like to slove different problem,because he think it is a way let him more intelligent. But as we know,yifenfei is weak in math. When he come up against a difficult math problem, he
always try to get a hand. Now the problem is coming! Let we

define T(n) as the sum of all numbers which are positive integers can divied n. and S(n) = T(1) + T(2) + T(3)…..+T(n).

 

[align=left]Input[/align]
The first line of the input contains an integer T which means the number of test cases. Then T lines follow, each line consists of only one positive integers n. You may assume the integer will not exceed 2^31.
 

[align=left]Output[/align]
For each test case, you should output one lines of one integer S(n) %2. So you may see the answer is always 0 or 1 .
 

[align=left]Sample Input[/align]

3
1
2
3

 

[align=left]Sample Output[/align]

1
0
0

HintHint S(3) = T(1) + T(2) +T(3) = 1 + (1+2) + (1+3) = 8
S(3) % 2 = 0

 

[align=left]
[/align]
[align=left]
[/align]
[align=left]
[/align]
[align=left]
[/align]
[align=left]
[/align]

凡是“能够被完全开方”或者“被2整除后能够完全被开方”的数,它的(T(N)
% 2)都是1。

#include<stdio.h>
#include<math.h>
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,count=0;
scanf("%d",&n);
for(int i=1;i<=n;i++)
{
if(i*i*2<=n)count++;
if(i*i<=n)count++;
else break;
}
printf("%d\n",count%2);
}
return 0;
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: