您的位置:首页 > 大数据 > 人工智能

HDU 1022 Train Problem I

2016-05-29 00:21 344 查看

Train Problem I

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
[/align]
[align=center]Total Submission(s): 30516    Accepted Submission(s): 11536
[/align]

[align=left]Problem Description[/align]
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes
a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves,
train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your
task is to determine whether the trains can get out in an order O2.







 

[align=left]Input[/align]
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file.
More details in the Sample Input.

 

[align=left]Output[/align]
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out"
for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

 
[align=left]Sample Input[/align]

3 123 321
3 123 312

 

[align=left]Sample Output[/align]
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

这道题目就是问你火车出站按题目给出的方式编程来实现判断是否可行,可行输出Yes,并分别输出进站出站的顺序,不行则输出No;要用到栈的相关知识。

#include<iostream>
#include<stack>
#include<cstring>
using namespace std;
stack <char> s;
int main()
{
int n;char at[20];char bt[20];
memset(at,0,20);
memset(bt,0,20);
while(cin>>n>>at>>bt)
{
int ft[40];int flag=0;int tag=0;
while( !s.empty() )s.pop();
for(int i=0;i<n;)
{
if(s.empty())
{
s.push(at[i++]);
ft[flag++]=1;
continue;
}
if(s.top()==bt[tag])
{
tag++;
ft[flag++]=0;
s.pop();
} else

{
s.push(at[i++]);
ft[flag++]=1;
}
}
if(!s.empty())
{
while(1)
{
if(s.empty())break;
if(s.top()==bt[tag])
{
s.pop();
ft[flag++]=0;
tag++;
} else break;
}
}
if(flag==2*n)
{
cout<<"Yes."<<endl;
for(int i=0;i<flag;i++)
{
if(ft[i]==1)cout<<"in"<<endl;
else cout<<"out"<<endl;
}
}
else
{
cout<<"No."<<endl;
}
cout<<"FINISH"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: