您的位置:首页 > 产品设计 > UI/UE

hdu 2590 Building roads(环+贪心)

2016-05-28 14:37 423 查看


Building roads

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 121 Accepted Submission(s): 13



Problem Description

There is a circle-shape lake in a beautiful town. And along the lake, there are N cities, living lots of pigs.

In 2008, the number of pigs is growing so faster that the government decide to transfer some pigs from some cities to others. And they want to make that each city has the same number of pigs.

Before the transfer, the government has to build some roads between cities. For example, if we want to move some pigs from city A to city B, we have to build a road between A and B. Now the government wants to save more money for the National's Day, so they
want to build roads as few as possible, i.e, they want to know how many roads at least they have to build to make that each city has the same number of pigs.



Giving the initial number of pigs of each city, you should tell me the least number of roads have to build. If it is impossible to make each city has the same number of pigs, output "Impossible".

Input

There will be multiple input sets. The first line of input will contain a integer K, means the number of sets.

Input for each set is a positive integer n(means the number of cities, 1 <= n <= 10000) on a line by itself, followed one line containing some positive integers(no more than 10000), indicate the cities' initial number of pigs.

Output

Output for each input set should be one line containing a positive integer R, means the least number of roads have to build, output "Impossible" if it is impossible to make each city has the same number of pigs

Sample Input

4
3
1 2 3
3
2 2 2
4
1 3 1 3
3
1 3 3


Sample Output

1
0
2
Impossible

solution:
若平均值为整数,那么我们把每个值都减去平均值,这样一圈的和为0,很显然,最多需要n-1次,如果我们划分出了m个和为零的区间,那么最多需要n-m次。
#include<cstdio>
#include<algorithm>
#include<map>
using namespace std;
const int maxn = 1e4 + 200;
int a[maxn];
int main()
{
int t, n, x;
scanf("%d", &t);
while (t--)
{
scanf("%d", &n);
int ans =1e9;
long long sum = 0,sum1=0;
map<long long, int>q;
for (int i = 0; i < n; i++)
{
scanf("%d", &a[i]);
sum1 += a[i];
}
if (sum1%n != 0)
{
printf("Impossible\n");
continue;
}
for (int i = 0; i < n; i++)
{
a[i] -= sum1 / n;
sum += a[i];
q[sum]++;
ans = min(ans, n - q[sum]);
}
printf("%d\n", ans);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: