您的位置:首页 > 产品设计 > UI/UE

HDU 1242 Rescue(BFS+优先队列)

2016-05-28 14:27 399 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1242

题面:


Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25017    Accepted Submission(s): 8862


Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.

 

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 

 

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

 

Sample Output

13

 

Author

CHEN, Xue

 

Source

ZOJ Monthly, October 2003

 
解题:

    从a出发去找r,用优先队列,当前cost值小的,优先级高,只要找到一个r就可以结束了。

代码:

#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <queue>
#include <cstring>
#include <algorithm>
#define eps 1e-8
#define LL long long
using namespace std;
int n,m,ans,dir[4][2]={0,-1,-1,0,0,1,1,0};
char mapp[202][202];
bool vis[202][202];
struct step
{
int x,y,cost;
bool operator <(const step &b)const
{
return cost>b.cost;
}
};
priority_queue <step> qe;
void bfs(int x,int y)
{
while(!qe.empty())
qe.pop();
int tx,ty;
step tmp,cur;
tmp.x=x;
tmp.y=y;
tmp.cost=0;
qe.push(tmp);
while(!qe.empty())
{
cur=qe.top();
qe.pop();
for(int i=0;i<4;i++)
{
tx=cur.x+dir[i][0];
ty=cur.y+dir[i][1];
if(tx>=1&&tx<=n&&ty>=1&&ty<=m&&!vis[tx][ty])
{
if(mapp[tx][ty]=='r')
{
vis[tx][ty]=1;
ans=cur.cost+1;
return;
}
else if(mapp[tx][ty]=='x')
{
tmp.x=tx;
tmp.y=ty;
tmp.cost=cur.cost+2;
qe.push(tmp);
}
else
{
vis[tx][ty]=1;
tmp.x=tx;
tmp.y=ty;
tmp.cost=cur.cost+1;
qe.push(tmp);
}
}
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
int xa,ya,cnt=0;
memset(vis,0,sizeof(vis));
ans=50000;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
scanf(" %c",&mapp[i][j]);
if(mapp[i][j]=='a')
{
xa=i;
ya=j;
vis[i][j]=1;
}
else if(mapp[i][j]=='r')
{
cnt++;
}
else if(mapp[i][j]=='#')
vis[i][j]=1;
}
}
if(cnt==0)
printf("Poor ANGEL has to stay in the prison all his life.\n");
else
{
bfs(xa,ya);
if(ans==50000)
printf("Poor ANGEL has to stay in the prison all his life.\n");
else
printf("%d\n",ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu 搜索