您的位置:首页 > 其它

HDU2222 Keywords Search [AC自动机模板]

2016-05-25 23:38 267 查看


Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 50435    Accepted Submission(s): 16233


Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

 

Input

First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

 

Output

Print how many keywords are contained in the description.

 

Sample Input

1
5
she
he
say
shr
her
yasherhs

 

Sample Output

3

 

Author

Wiskey

把kmp和trie树组合起来,就是AC自动机。利用fail指针在失配时,在trie树中寻找上一个匹配点

目前并没有完全弄懂。理解大概还要好久

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<cstring>
using namespace std;
struct ACa
{
int next[500050][26];
int fail[500050],end[500050];
int root,cnt;//根结点,计数器
int newnode(){
for(int i=0;i<26;i++){
next[cnt][i]=-1;//子结点设为空
}
end[cnt++]=0;//以该结点结束的串数
return cnt-1;
}
int clear(){//初始化
cnt=0;//结点数重置
root=newnode();//初始化根结点 //完成后root=0
}
int insert(char c[]){
int now=root;
int len=strlen(c);
for(int i=0;i<len;i++){
if(next[now][c[i]-'a']==-1)//如果对应结点未建立,添加结点
next[now][c[i]-'a']=newnode();
now=next[now][c[i]-'a'];//否则沿结点继续
}
end[now]++;
}
void build(){
queue<int>q;
fail[root]=root;
for(int i=0;i<26;i++){
if(next[root][i]==-1)
next[root][i]=root;
else{//有结点则入队
fail[next[root][i]]=root;
q.push(next[root][i]);
}
}
while(!q.empty())
{
int now=q.front();
q.pop();
for(int i=0;i<26;i++){
if(next[now][i]==-1)
next[now][i]=next[fail[now]][i];//链接到fail指针对应结点的后面
else{
fail[next[now][i]]=next[fail[now]][i];
q.push(next[now][i]);
}
}
}
}
int query(char c[]){//查询
int len=strlen(c);
int now=root;
int res=0;
for(int i=0;i<len;i++){
now=next[now][c[i]-'a'];
int temp=now;
while(temp!=root)
{
res+=end[temp];
end[temp]=0;
temp=fail[temp];
}
}
return res;
}
};
char buf[1000500];
ACa ac;
int main(){
int T,n;
scanf("%d",&T);
while(T--){
scanf("%d",&n);
ac.clear();
int i;
for(i=1;i<=n;i++){
scanf("%s",buf);
ac.insert(buf);
}
ac.build();
scanf("%s",buf);
printf("%d\n",ac.query(buf));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  OI