您的位置:首页 > 编程语言 > PHP开发

hdu 1096 A+B for Input-Output Practice (VIII)

2016-05-22 22:51 786 查看

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 135986 Accepted Submission(s): 41510

[align=left]Problem Description[/align]
Your task is to calculate the sum of some integers.

[align=left]Input[/align]
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.

[align=left]Output[/align]
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.

[align=left]Sample Input[/align]

3 4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

[align=left]Sample Output[/align]

10

15

6

#include <iostream>
using namespace std;
int main() {
int test;
int a, b;
cin >> test;

while(test--)
{
int sum = 0;
int temp, n;
cin >> n;
for(int i = 0; i < n; i++)
{
cin >> temp;
sum += temp;
}
if(test != 0)
cout << sum << endl << endl;
else
cout << sum << endl;
}

return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: