您的位置:首页 > 其它

CodeForces - 672D Robin Hood (二分)好题

2016-05-21 11:04 471 查看
CodeForces - 672D
Robin Hood

Time Limit: 1000MS Memory Limit: 262144KB 64bit IO Format: %I64d & %I64u
SubmitStatus

Description

We all know the impressive story of Robin Hood. Robin Hood uses his archery skills and his wits to steal the money from rich, and return it to the poor.

There are n citizens in Kekoland, each person has
ci coins. Each day, Robin Hood will take exactly
1 coin from the richest person in the city and he will give it to the poorest person (poorest person right after taking richest's
1 coin). In case the choice is not unique, he will select one among them at random. Sadly, Robin Hood is old and want to retire in
k days. He decided to spend these last days with helping poor people.

After taking his money are taken by Robin Hood richest person may become poorest person as well, and it might even happen that Robin Hood will give his money back. For example if all people have same number of coins, then next day they will have same number
of coins too.

Your task is to find the difference between richest and poorest persons wealth after
k days. Note that the choosing at random among richest and poorest doesn't affect the answer.

Input

The first line of the input contains two integers n and
k (1 ≤ n ≤ 500 000, 0 ≤ k ≤ 109) — the number of citizens in Kekoland and the number of days left till Robin Hood's retirement.

The second line contains n integers, the
i-th of them is ci (1 ≤ ci ≤ 109)
— initial wealth of the i-th person.

Output

Print a single line containing the difference between richest and poorest peoples wealth.

Sample Input

Input
4 1
1 1 4 2


Output
2


Input
3 1
2 2 2


Output
0


Sample Output

Hint

Source
Codeforces Round #352 (Div. 2)
//题意:
一个城市里有n个人,他们都以一定数量的硬币a[i],现在你每天从最富的那个人的手里拿一个硬币给最贫穷的人,这样进行操作k天,问k天后最富的人比最穷的人多几个硬币?
//思路:
首先得明确一点,初始时硬币数比平均数少的人最终会增加k个硬币,比平均数多的会减少k个硬币,所以根据这个先用二分求出最终最少的硬币数,然后最用二分求出最终最多的硬币数,然后相减就行了
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define INF 0x3f3f3f3f
#define ll long long
#define N 500010using namespace std;
ll a
;
int main()
{
ll n,k;
int i,j;
while(scanf("%lld%lld",&n,&k)!=EOF)
{
ll sum=0;
for(i=0;i<n;i++)
{
scanf("%lld",&a[i]);
sum+=a[i];
}
sort(a,a+n);
ll la=sum/n;
ll ra=(sum+n-1)/n;
ll l=0,r=la,ans1=0;
while(l<=r)
{
ll mid=(l+r)>>1;
ll kk=0;
for(i=0;i<n;i++)
{
if(mid>=a[i])
kk+=mid-a[i];
}
if(kk<=k)
ans1=mid,l=mid+1;
else
r=mid-1;
}
l=ra;r=INF;
ll ans2=0;
while(l<=r)
{
ll mid=(l+r)>>1;
ll kk=0;
for(i=0;i<n;i++)
{
if(mid<=a[i])
kk+=a[i]-mid;
}
if(kk<=k)
ans2=mid,r=mid-1;
else
l=mid+1;
}
printf("%lld\n",ans2-ans1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: