您的位置:首页 > 其它

HDU - 4004 The Frog's Games (二分)去掉m个石头求最小间距

2016-06-01 14:13 344 查看
HDU - 4004
The Frog's Games

Time Limit:                                                        1000MS                        Memory Limit: 65768KB 64bit IO Format:                            %I64d & %I64u                       
SubmitStatus

Description

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river
is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they

are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).      

               

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m.       

Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.      

               

Output

For each case, output a integer standing for the frog's ability at least they should have.      

               

Sample Input

6 1 2
2
25 3 3
11
2
18

               

Sample Output

4
11

               

Hint

Source
The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest
//题意:
先输入三个数,L,n,m表示一条河的宽度为L,在河的中间有n块石头,最多只能跳m次,问怎样跳使得青蛙的跳的m次中最大的消耗值最小。
//思路:
直接二分,判断两次就行了
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define N 500010
using namespace std;
int L,n,m;
int a
;
bool judge(int mid)
{
int i,j,last=a[0];
int cnt=0;
for(i=1;i<=n;i++)
{
if(a[i]-a[i-1]>mid)
return false;
if(a[i]-last>mid)
{
cnt++;
last=a[i-1];
if(cnt>=m)
return false;
}
}
return true;
}
int erfen(int l,int r)
{
int mid,ans;
while(l<=r)
{
mid=(l+r)>>1;
if(judge(mid))
{
ans=mid;
r=mid-1;
}
else
l=mid+1;
}
return ans;
}
int main()
{

int i,j;
while(scanf("%d%d%d",&L,&n,&m)!=EOF)
{
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
a[0]=0;a[++n]=L;
sort(a,a+n+1);
printf("%d\n",erfen(0,L));
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: