您的位置:首页 > 其它

HDU 4006 The kth great number (优先队列)

2016-05-18 13:32 344 查看


The kth great number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 9361 Accepted Submission(s): 3727



Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help
Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao
Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q


Sample Output

1
2
3
大体题意:给你n个操作和一个数值k每一个操作可以插入一个数,也可以查询在已经插入的数中第K大的是多少!
思路:优先队列模拟,优先队列按小数优先!优先队列只存K个数当插入一个数后,发现大小大于K了 ,则pop()#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
struct cmp{
bool operator() (int &a,int &b){
return a > b;
}
};
priority_queue<int,vector<int>,cmp>q;
int main(){

int n,k;
while(scanf("%d%d",&n,&k) == 2){
while(!q.empty())q.pop();
int deep = 0;
while(n--){
char s[5];
scanf("%s",s);
if (s[0] == 'I'){
int v;
scanf("%d",&v);
q.push(v);
++deep;
if (deep > k)q.pop(),--deep;
}
else printf("%d\n",q.top());
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: