您的位置:首页 > 其它

hdu 4496(并查集的边删除)

2016-05-13 14:45 344 查看

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)

[align=left]Problem Description[/align]
Luxer is a really bad guy. He destroys everything he met.

One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines
in the input.

Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

[align=left]Input[/align]
First line of the input contains two integers N and M.

Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.

Constraints:

0 < N <= 10000

0 < M <= 100000

0 <= u, v < N.

 

[align=left]Output[/align]
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

[align=left]Sample Input[/align]

5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

 

[align=left]Sample Output[/align]

1
1
1
2
2
2
2
3
4
5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

 
解题思路:这道题看似删除边要重新构图,但实际上如果反着想就很明白了,按照输入边的逆序去建图,不就变得很简单了嘛。。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 10005;
struct Edge
{
int u,v;
}edge[100005];
int n,m,block,fa[maxn],ans[100005];

int find(int x)
{
if(fa[x] == x) return x;
return fa[x] = find(fa[x]);
}

int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i = 1; i <= m; i++)
scanf("%d%d",&edge[i].u,&edge[i].v);
for(int i = 0; i < n; i++) fa[i] = i;
block = n;
ans[m] = block;
for(int i = m; i > 1; i--)
{
int u = edge[i].u;
int v = edge[i].v;
if(find(u) != find(v))
{
fa[find(v)] = find(u);
block--;
}
ans[i-1] = block;
}
for(int i = 1; i <= m; i++)
printf("%d\n",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  LCA并查集