您的位置:首页 > 其它

Charm Bracelet

2016-05-04 10:53 246 查看
0-1背包裸题,没优化过不了

http://poj.org/problem?id=3624


Charm Bracelet

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 31660 Accepted: 14076
Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1
≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input
4 6
1 4
2 6
3 12
2 7

Sample Output
23

Source

USACO 2007 December Silver
设dp[i][j]表示在前i个物品中选择一些在总体积<=j的情况下所获得的最大美值。
dp[1][i]=d[1];if(w[1]<=i),else dp[1][i]=0;

转移方程:

dp[i][j]=max(dp[i-1][j],dp[i-1][j-w[i]]+d[i]);后一项成立条件是j>=w[i];

代码用滚动数组优化

//dp500-6
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1<<30;
const int SIZE=4e4+10;
int w[SIZE],d[SIZE];
int dp[20000];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF){
for(int i=1;i<=n;i++)
scanf("%d%d",&w[i],&d[i]);
for(int i=0;i<=m;i++)//初始化操作dp[1][i]
if(w[1]<=i){

4000
dp[i]=d[1];
}
else dp[1]=0;
for(int i=2;i<=n;i++)
for(int j=m;j>=0;j--){
if(j>=w[i])dp[j]=max(dp[j],dp[j-w[i]]+d[i]);
}
printf("%d\n",dp[m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: