您的位置:首页 > 其它

POJ 2594 Treasure Exploration

2016-05-03 19:35 351 查看
Language:
Default

Treasure Exploration

Time Limit: 6000MSMemory Limit: 65536K
Total Submissions: 7731Accepted: 3184
Description

Have you ever read any book about treasure exploration? Have you ever see any film about treasure exploration? Have you ever explored treasure? If you never have such experiences, you would never know what fun treasure exploring brings to you.

Recently, a company named EUC (Exploring the Unknown Company) plan to explore an unknown place on Mars, which is considered full of treasure. For fast development of technology and bad environment for human beings, EUC sends some robots to explore the treasure.

To make it easy, we use a graph, which is formed by N points (these N points are numbered from 1 to N), to represent the places to be explored. And some points are connected by one-way road, which means that, through the road, a robot can only move from one
end to the other end, but cannot move back. For some unknown reasons, there is no circle in this graph. The robots can be sent to any point from Earth by rockets. After landing, the robot can visit some points through the roads, and it can choose some points,
which are on its roads, to explore. You should notice that the roads of two different robots may contain some same point.

For financial reason, EUC wants to use minimal number of robots to explore all the points on Mars.

As an ICPCer, who has excellent programming skill, can your help EUC?
Input

The input will consist of several test cases. For each test case, two integers N (1 <= N <= 500) and M (0 <= M <= 5000) are given in the first line, indicating the number of points and the number of one-way roads in the graph respectively. Each of the following
M lines contains two different integers A and B, indicating there is a one-way from A to B (0 < A, B <= N). The input is terminated by a single line with two zeros.
Output

For each test of the input, print a line containing the least robots needed.
Sample Input
1 0
2 1
1 2
2 0
0 0

Sample Output
1
1
2


【题目分析】

路径是可以重复的,那么就不能用最小路径覆盖来做了。那么我们先用一次floyd,将所有可以到达的点拆成出入两个点两两相连,然后在使用匈牙利算法求最大匹配,然后用总结点数一减就可以了。

【代码】

#include <cstdio>
#include <cstring>
using namespace std;
#define M(a) memset(a,0,sizeof a)
#define F(i,j,k) for (int i=j;i<=k;++i)
int map[501][501],match[501],vis[501],line[501][501],n,m;
bool find(int x)
{
F(i,1,n)
if (line[x][i]&&vis[i]==0){
vis[i]=1;
if (!match[i]||find(match[i])){
match[i]=x;
return true;
}
}
return false;
}
int main()
{
while (scanf("%d%d",&n,&m)==2){
M(map);
M(line);
M(match);
M(vis);
if (n==0&&m==0) return 0;
F(i,1,n)F(j,1,n) map[i][j]=5000;
F(i,1,m){
int u,v;
scanf("%d%d",&u,&v);
map[u][v]=1;
}
F(k,1,n)F(i,1,n)F(j,1,n)
if (map[i][k]+map[k][j]<map[i][j]) map[i][j]=map[i][k]+map[k][j];
F(i,1,n)F(j,1,n)if (map[i][j]<5000&&i!=j) line[i][j]=1;
int ans=0;
F(i,1,n){M(vis); if(find(i)) ans++;}
printf("%d\n",n-ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: