您的位置:首页 > 其它

nyoj_18 The Triangle

2016-05-03 16:23 441 查看


The Triangle

时间限制:1000 ms | 内存限制:65535 KB
难度:4

描述

7

3 8

8 1 0

2 7 4 4

4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but
<= 100. The numbers in the triangle, all integers, are between 0 and 99.
输出Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5


样例输出
30


分析:

递推公式:dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])+map[i][j]

代码:

#include<stdio.h>
#include<string.h>
int max(int a,int b)
{
return a>=b?a:b;
}
int s[105][105];
int dp[105][105];
int main()
{
int N;
while(scanf("%d",&N)!=EOF)
{
memset(s,0,sizeof(s));
memset(dp,0,sizeof(dp));
int i,j;
for(i=0;i<N;i++)
for(j=0;j<=i;j++)
scanf("%d",&s[i][j]);
int ans=0;
dp[0][0]=s[0][0];
for(i=1;i<N;i++)
for(j=0;j<=i;j++)
if(j==0)
dp[i][j]=dp[i-1][j]+s[i][j];
else if(j==i)
dp[i][j]=dp[i-1][j-1]+s[i][j];
else
dp[i][j]=max(dp[i-1][j-1],dp[i-1][j])+s[i][j];
for(i=0;i<N;i++)
if(ans<dp[N-1][i])
ans=dp[N-1][i];
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: