您的位置:首页 > 移动开发

HDUT-2408-Pick apples(贪心+背包)

2016-05-03 10:42 423 查看

Pick apples


Time Limit: 1000ms Memory limit: 165536K 有疑问?点这里^_^

题目描述

Once ago, there is a mystery yard which only produces three kinds of apples. The number of each kind is infinite. A girl carrying a big bag comes into the yard. She is so surprised because she has never seen so many apples before. Each kind
of apple has a size and a price to be sold. Now the little girl wants to gain more profits, but she does not know how. So she asks you for help, and tell she the most profits she can gain.

输入

In the first line there is an integer T (T <= 50), indicates the number of test cases.

In each case, there are four lines. In the first three lines, there are two integers S and P in each line, which indicates the size (1 <= S <= 100) and the price (1 <= P <= 10000) of this kind of apple.

In the fourth line there is an integer V,(1 <= V <= 100,000,000)indicates the volume of the girl's bag.

输出

For each case, first output the case number then follow the most profits she can gain.

示例输入

11 12 13 16


示例输出

Case 1: 6


提示

来源

2012年"浪潮杯"山东省第三届ACM大学生程序设计竞赛

思路:大范围贪心,小范围背包。

只有三个物品,V=1e8, max(v)=100,可以贪心的取最大性价比到可背包范围,在进行背包。

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

long long V,dp[2010],s[5],p[5];

void CompletePack(long long ss,long long pp)
{
for(long long i=ss; i<=V; i++)
if(dp[i]<dp[i-ss]+pp)
dp[i]=dp[i-ss]+pp;
}

int main()
{
int T,cases=0;
scanf("%d",&T);
while(T--)
{
double val,max=0;
int id;
for(int i=0; i<3; i++)
{
cin>>s[i]>>p[i];
val=1.0*p[i]/s[i];
if(max<val)
{
max=val;
id=i;
}
}
cin>>V;
memset(dp,0,sizeof(dp));
cout<<"Case "<<++cases<<": ";
if(V<=500)
{
for(int i=0; i<3; i++)
CompletePack(s[i],p[i]);
cout<<dp[V]<<endl;
}
else
{
long long ans=(V-500)/s[id]*p[id];
V=V-(V-500)/s[id]*s[id];
for(int i=0; i<3; i++)
CompletePack(s[i],p[i]);
cout<<dp[V]+ans<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: