您的位置:首页 > 其它

hdu1061 Rightmost Digit 标准快速幂

2016-05-01 15:41 351 查看
Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2 3 4

Sample Output

7 6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

题目的意思呢, 就是给出一个数 N, 然后让你算N的N次幂, 看一下规模, 在10^9这个数量级, 慢慢乘肯定乘不出来了. 快速幂套模板直接AC

#include<iostream>
#include<cstdio>

using namespace std;
int xcpow(int x,int n){
long long ans=1,tmp=x%10;
while(n){
if(n&1)ans=ans*tmp%10;
tmp = tmp*tmp%10;
n>>=1;
}
return ans;
}
int main(){
int n,x;
cin>>n;
while(n--){
cin>>x;
cout<<xcpow(x,x)<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: