您的位置:首页 > 其它

hdu 2680 Choose the best route

2016-04-25 10:18 274 查看

Choose the best route

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12278 Accepted Submission(s):
3986


[align=left]Problem Description[/align]
One day , Kiki wants to visit one of her friends. As
she is liable to carsickness , she wants to arrive at her friend’s home as soon
as possible . Now give you a map of the city’s traffic route, and the stations
which are near Kiki’s home so that she can take. You may suppose Kiki can change
the bus at any station. Please find out the least time Kiki needs to spend. To
make it easy, if the city have n bus stations ,the stations will been expressed
as an integer 1,2,3…n.

[align=left]Input[/align]
There are several test cases.
Each case begins with
three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the
number of bus stations in this city and m stands for the number of directed ways
between bus stations .(Maybe there are several ways between two bus stations .)
s stands for the bus station that near Kiki’s friend’s home.
Then follow m
lines ,each line contains three integers p , q , t (0<t<=1000). means from
station p to station q there is a way and it will costs t minutes .
Then a
line with an integer w(0<w<n), means the number of stations Kiki can take
at the beginning. Then follows w integers stands for these stations.

[align=left]Output[/align]
The output contains one line for each data set : the
least time Kiki needs to spend ,if it’s impossible to find such a route ,just
output “-1”.

[align=left]Sample Input[/align]

5 8 5
1 2 2
1 5 3

1 3 4

2 4 7

2 5 6
2 3 5

3 5 1

4 5 1
2

2 3

4 3 4
1 2 3
1 3 4

2 3 2

1
1

[align=left]Sample Output[/align]

1
-1

[align=left]Author[/align]
dandelion

[align=left]Source[/align]
2009浙江大学计算机研考复试(机试部分)——全真模拟

[align=left]Recommend[/align]
lcy | We have carefully selected several similar
problems for you: 1142 1385 2923 1690 1596

很简单的迪杰斯特拉,和以前做的一道题是一样的,因为有多个起点,所以将0作为起点,到所有原本起点的距离为0即可。

题意:给出n个站,m条路(有向)和终点站。输入m条点到点的距离,再给出q,表示可作为起点的站编号,给出这q个编号,求最短路。

附上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#define inf 0x3f3f3f3f
#define M 1005
using namespace std;
int map[M][M],vis[M],dis[M];
int main()
{
int i,j,n,m,s;
while(~scanf("%d%d%d",&n,&m,&s))
{
memset(vis,0,sizeof(vis));
memset(dis,0,sizeof(dis));
for(i=0; i<=n; i++)
for(j=0; j<=n; j++)
{
if(i==j) map[i][j]=0;
else     map[i][j]=inf;
}
int a,b,c;
for(i=0; i<m; i++)
{
scanf("%d%d%d",&a,&b,&c);
if(map[a][b]>c)
map[a][b]=c;
}
int w,q;
scanf("%d",&w);
for(i=0; i<w; i++)
{
scanf("%d",&q);
map[0][q]=0;   //将0作为起点!
}
for(i=0; i<=n; i++)
dis[i]=map[0][i];
vis[0]=1;
int min,t;
for(i=1; i<=n; i++)
{
min=inf;
for(j=1; j<=n; j++)
if(!vis[j]&&min>dis[j])
{
min=dis[j];
t=j;
}
vis[t]=1;
for(j=1; j<=n; j++)
if(!vis[j]&&map[t][j]<inf)
if(dis[j]>dis[t]+map[t][j])
dis[j]=dis[t]+map[t][j];
}
if(dis[s]<inf)
printf("%d\n",dis[s]);
else
printf("-1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: