您的位置:首页 > 其它

hdu 3974 线段树 将树弄到区间上

2016-04-22 17:23 267 查看

Assign the task

Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1647 Accepted Submission(s): 753


[align=left]Problem Description[/align]
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

[align=left]Input[/align]
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)

[align=left]Output[/align]
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

[align=left]Sample Input[/align]

1
5
4 3
3 2
1 3
5 2
5
C 3
T 2 1
C 3
T 3 2
C 3

[align=left]Sample Output[/align]

Case #1:
-1
1
2

/*
hdu 3974 线段树 将树弄到区间上

题意: 给定一棵树,50000个节点,50000个操作
C x表示查询x节点的值,
T x y表示更新x节点及其子节点的值为y

没想到的是普通并查集都能过,数据是由多水 - -

由于T操作每次更新当前节点以及它的子树,所有dfs一次,给每个节点进行编号。 每次更新
就成了对当前节点所覆盖区间的更新。

hhh-2016-04-22 14:09:04
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <functional>
using namespace std;
#define lson  (i<<1)
#define rson  ((i<<1)|1)
typedef long long ll;
using namespace std;
const ll mod = 1e9 + 7;
const int  maxn = 50010;

struct node
{
int l,r;
int val;
int lazy;
int mid() {return (l+r) >> 1;}
}tree[maxn<<2];

int tot,cnt;
int rt[maxn];
int st[maxn],ed[maxn];
vector <int > vec[maxn];
void dfs(int cur)
{
st[cur] = ++cnt;
for(int i = 0;i < vec[cur].size();i++)
{
dfs(vec[cur][i]);
}
ed[cur] = cnt;
}

void build(int i,int l,int r)
{
tree[i].l = l,tree[i].r = r;
tree[i].val = -1,tree[i].lazy = 0;
if(l == r)
return ;
int mid = tree[i].mid();
build(lson,l,mid);
build(rson,mid+1,r);
}

void push_down(int i)
{
if(tree[i].lazy)
{
tree[lson].val = tree[i].val,tree[lson].lazy = 1;
tree[rson].val = tree[i].val,tree[rson].lazy = 1;
tree[i].lazy = 0;
}
}

void update(int i,int l,int r,int val)
{
if(tree[i].l >= l && tree[i].r <= r)
{
tree[i].val = val;
tree[i].lazy = 1;
return ;
}
push_down(i);
int mid = tree[i].mid();
if(l <= mid)
update(lson,l,r,val);
if(r > mid)
update(rson,l,r,val);
//    if(r <= mid)
//        update(lson,l,r,val);
//    else if(l > mid)
//        update(rson,l,r,val);
//    else
//    {
//        update(lson,l,mid,val);
//        update(rson,mid+1,r,val);
//    }
return ;
}

int query(int i,int k)
{
if(tree[i].l == k && tree[i].r == k)
return tree[i].val;
int mid = tree[i].mid();
push_down(i);
if(k <= mid)
return query(lson,k);
else
return query(rson,k);
}

int main()
{
int T,n,m,x,y;
int cas = 1;
scanf("%d",&T);
while(T--)
{
cnt = 0;
scanf("%d",&n);
printf("Case #%d:\n",cas++);
for(int i = 1;i <= n;i++)
{
vec[i].clear();
}
memset(rt,0,sizeof(rt));
int u,v;
for(int i = 1;i < n;i++)
{
scanf("%d%d",&u,&v);
vec[v].push_back(u);
rt[u] = 1;
}
int rot;
for(int i = 1;i <= n;i++)
{
if(!rt[i])
{
rot = i;
break;
}
}
dfs(rot);
build(1,1,cnt);
char op[10];
scanf("%d",&m);
for(int i = 1;i <= m;i++)
{
scanf("%s",op);
if(op[0] == 'C')
{
scanf("%d",&x);
printf("%d\n",query(1,st[x]));
}
else if(op[0] == 'T')
{
scanf("%d%d",&x,&y);
update(1,st[x],ed[x],y);
}
}
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: