您的位置:首页 > 大数据 > 人工智能

HDU 5319 Painter

2016-04-21 19:03 471 查看
..

Painter

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 886    Accepted Submission(s): 404


[align=left]Problem Description[/align]Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state. 
[align=left]Input[/align]The first line is an integer T describe the number of test cases.
Each test case begins with an integer number n describe the number of rows of the drawing board.
Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.
1<=n<=50
The number of column of the rectangle is also less than 50.
Output
Output an integer as described in the problem description.
 
[align=left]Output[/align]Output an integer as described in the problem description. 
[align=left]Sample Input[/align]
2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR 
[align=left]Sample Output[/align]
3

[align=left]Author[/align]ZSTU 
[align=left]Source[/align]2015 Multi-University Training Contest 3
模拟判断当前点的右下,右上是否与当前点的颜色相同(在判断右下时G当成R,在判断右上时G看成B),如果颜色不同那么就需要paint一次。paint的总数就是答案。
/* ***********************************************
Author :
Created Time :2015/7/30 19:45:12
File Name :1.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 1<<30
#define maxn 10000+10
#define cle(a) memset(a,0,sizeof(a))
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;

bool cmp(int a,int b){
return a>b;
}
char mp[55][55];
int n,m;
int main()
{
#ifndef ONLINE_JUDGE
freopen("in.txt","r",stdin);
#endif
//freopen("out.txt","w",stdout);
int t;
cin>>t;
while(t--){
cle(mp);
cin>>n;
getchar();
gets(mp[1]);
m=strlen(mp[1]);
for(int i=2;i<=n;i++){
gets(mp[i]);
}
int ans=0;
for(int i=1;i<=n;i++)
for(int j=0;j<m;j++){
if((mp[i][j]=='R'||mp[i][j]=='G')&&!(mp[i+1][j+1]=='R'||mp[i+1][j+1]=='G'))
ans++;
if((mp[i][j]=='B'||mp[i][j]=='G')&&!(mp[i-1][j+1]=='B'||mp[i-1][j+1]=='G'))
ans++;
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: