您的位置:首页 > 其它

UVA 558 Wormholes(有向图的传递闭包)

2016-04-20 19:47 302 查看
Wormholes
Time Limit:3000MS Memory Limit:0KB 64bit
IO Format:
%lld & %llu

Description

In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties:

Wormholes are one-way only.

The time it takes to travel through a wormhole is negligible.

A wormhole has two end points, each situated in a star system.

A star system may have more than one wormhole end point within its boundaries.

For some unknown reason, starting from our solar system, it is always possible to end up in any star system by following a sequence of wormholes (maybe Earth is the centre of the universe).

Between any pair of star systems, there is at most one wormhole in either direction.

There are no wormholes with both end points in the same star system.

All wormholes have a constant time difference between their end points. For example, a specific wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole may cause the person to end up 42 years in the past.

A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp drive has not been invented yet, it is not possible for her to travel from one star system to another one directly. This can be done using wormholes, of
course.

The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in time as necessary to reach the beginning of the universe
and see the Big Bang with her own eyes. Write a program to find out whether such a cycle exists.


Input

The input file starts with a line containing the number of cases c to
be analysed. Each case starts with a line with two numbers n and m .
These indicate the number of star systems (

)
and the number of wormholes (

)
. The star systems are numbered from 0 (our solar system) through n-1
. For each wormhole a line containing three integer numbers x, y and t is
given. These numbers indicate that this wormhole allows someone to travel from the star system numbered x to
the star system numbered y, thereby ending up t (

)
years in the future.


Output

The output consists of c lines,
one line for each case, containing the word possible if it is indeed possible to
go back in time indefinitely, or not possible if this is not possible with the given
set of star systems and wormholes.


Sample Input

2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60



Sample Output

possible
not possible


最小生成树? 最短路径? 有负权值,并且题目中要的是能够无限的回到过去,那么肯定需要有个环,并且该环的总权值为负的,这样才能无限的回到过去,所以 floyd 算法是最好的选择,有向图的传递闭包。用floyd求出任意两点之间的最小权重,这里两点可以的同一个点,也必须要有两个点是同一个点(为了形成环),然后判断自己到自己的权重有没有为负的,如果有,那就是 possible ,反之 则为 not possible

附上代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<queue>

using namespace std;
const int INF = 0x3f3f3f3f;
int path[1100][1100];
int main()
{
int t;
cin >> t;
while(t--)
{
memset(path,INF,sizeof(path));     //  将所有的路径全部初始化为最大值INF
int n,m;
cin >> n >> m;
for(int i = 0;i < m;i++)
{
int a,b,c;
cin >> a >> b >> c;
path[a][b] = c;
}
for(int i = 0;i < n;i++)
{
for(int j = 0;j < n;j++)
{
if(path[j][i] == INF)           //   这个if 语句和下面的if语句必须要,不然会超时,在这点只有 m 个 path[j][i] 成立,执行第三层循环,<span style="font-family: 'times new roman';">能够很大程度 减少循环的次数</span>

continue;
for(int k = 0;k < n;k++)
{
if(path[i][k] == INF)   //  这个同上
continue;
path[j][k] = min(path[j][k],path[j][i] + path[i][k]);
}
}
}
int ans = 0;
for(int i = 0;i < n;i++)        //   判断 n 个节点中有没有自己到达自己的权值是负的
{
if(path[i][i] < 0)       //  如果有权值为负,则有能够 possible
{
ans = 1;
break;
}
}
if(ans)
cout << "possible" << endl;
else
cout << "not possible" << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: