您的位置:首页 > 其它

POJ-3100-Root of the Problem,原来是水题,暴力求解~~~

2016-04-15 19:43 411 查看
Root of the Problem

Time Limit: 1000MSMemory Limit: 65536K














http://poj.org/problem?id=3100 已AK;

Description

Given positive integers B and N, find an integer A such that AN is as close as possible to B. (The result A is an approximation to the Nth root of B.) Note that AN may be less than, equal to, or greater than B.

Input

The input consists of one or more pairs of values for B and N. Each pair appears on a single line, delimited by a single space. A line specifying the value zero for both B and N marks the end of the input. The value of B will be in the range 1 to 1,000,000
(inclusive), and the value of N will be in the range 1 to 9 (inclusive).

Output

For each pair B and N in the input, output A as defined above on a line by itself.

Sample Input
4 3
5 3
27 3
750 5
1000 5
2000 5
3000 5
1000000 5
0 0

Sample Output
1
2
3
4
4
4
5
16

Source

Mid-Central USA 2006

题意应该很好看懂,给你B,K,求A^K最接近B的那个A是多少,当时想了一会,没什么思路,,差点用快速幂求了,不过认真看题发现数据范围并不大,B才在百万级内,完全可以用暴力解决, 要知道2^20等于1024*1024>1000000,即最大只需for遍历到20就可以了;

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
int x,k,i;
while(~scanf("%d%d",&x,&k)&&x&&k)
{
if(k==1)
printf("%d\n",x);
else if(k>=x)//如果相等,2^k次方肯定远大于x;
printf("1\n");
else
{
for(i=1;;i++)//遍历求出满足条件A的范围;
if((int)pow(i*1.0,k)<=x&&x<=(int)pow((i+1)*1.0,k))
break;
if(abs((int)pow(i*1.0,k)-x)<=abs((int)pow((i+1)*1.0,k)-x))
printf("%d\n",i);
else
printf("%d\n",i+1);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: