您的位置:首页 > 产品设计 > UI/UE

POJ 2524 Ubiquitous Religions【并查集模板】

2016-04-15 12:59 323 查看
Ubiquitous Religions

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 30276 Accepted: 14656
Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound
of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.
Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The
end of input is specified by a line in which n = m = 0.
Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output
Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

题目大意:每个人的宗教信仰都不同,给出n个人,m个关系,表示a和b的信仰相同。询问一共有多少种信仰。

思路:把每个人都看成一个节点,信仰相同的并到一个集合里边,询问有多少种信仰的含义就是在询问一共有多少个祖宗节点。

并查集水题,AC代码:
#include<stdio.h>
#include<string.h>
using namespace std;
int f[121212];
int find(int x)
{
return f[x] == x ? x : (f[x] = find(f[x]));
}
void merge(int a,int b)
{
int A,B;
A=find(a);
B=find(b);
if(A!=B)
f[B]=A;
}
int main()
{
int n,m,kase=0;
while(~scanf("%d%d",&n,&m))
{
if(n==0&&m==0)break;
for(int i=1;i<=n;i++)f[i]=i;
while(m--)
{
int x,y;
scanf("%d%d",&x,&y);
merge(x,y);
}
int cont=0;
for(int i=1;i<=n;i++)
{
if(f[i]==i)cont++;
}
printf("Case %d: %d\n",++kase,cont);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ 2524