您的位置:首页 > 其它

杭电ACM 1005

2016-04-13 08:39 253 查看
Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3

1 2 10

0 0 0

Sample Output

2

5

解析:这个题关键是两个模7 进行49次就会 出现循环,所以我们可以将这 49个值 存储起来

看读懂的朋友可以将中间那行注释去掉,跑一下看看就知道了

import java.util.Scanner;

public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int[] template=new int[53];
template[1]=1;
template[2]=1;
while(scanner.hasNext()){
int a=scanner.nextInt();
int b=scanner.nextInt();
int n=scanner.nextInt();
if(a==0&&b==0&&n==0)
break;
if(n==1||n==2)
System.out.println(1);
else{
for(int i=3;i<53;i++){
template[i]=(a*template[i-1]+b*template[i-2])%7;
//System.out.println("i-->"+i+" value-->"+template[i]);
}
System.out.println(template[n%49]);
}
}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: