您的位置:首页 > 大数据 > 人工智能

hdu 1021 Fibonacci Again

2016-04-11 00:31 405 查看


Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 50368 Accepted Submission(s): 23858



Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5


Sample Output

no
no
yes
no
no
no


Author

Leojay

学好英文很重要,就是问你这个数列的第n项是否可以被3整除;

#include<iostream>
#include<cstdio>
using namespace std;
int ans[1000000];
int main()
{
ans[0]=7;
ans[1]=11;
for(int i=2;i<1000000;++i)
{
ans[i]=(ans[i-1]+ans[i-2])%3;
}
int n;
while(scanf("%d",&n)!=EOF)
{
if(ans
==0)
puts("yes");
else
puts("no");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: