您的位置:首页 > 其它

微软2016校园招聘4月在线笔试 hihocoder 1288 Font Size (模拟)

2016-04-07 14:20 459 查看
时间限制:10000ms
单点时限:1000ms
内存限制:256MB

描述

Steven loves reading book on his phone. The book he reads now consists of N paragraphs and the i-th paragraph contains ai characters.

Steven wants to make the characters easier to read, so he decides to increase the font size of characters. But the size of Steven's phone screen is limited. Its width is W and height is H. As a result, if the font size of characters
is S then it can only show ⌊W / S⌋ characters in a line and ⌊H / S⌋ lines in a page. (⌊x⌋ is the largest integer no more than x)  

So here's the question, if Steven wants to control the number of pages no more than P, what's the maximum font size he can set? Note that paragraphs must start in a new line and there is no empty line between paragraphs.

输入

Input may contain multiple test cases.

The first line is an integer TASKS, representing the number of test cases.

For each test case, the first line contains four integers N, P, W and H, as described above.

The second line contains N integers a1, a2, ... aN, indicating the number of characters in each paragraph.

For all test cases,

1 <= N <= 103,

1 <= W, H, ai <= 103,

1 <= P <= 106,

There is always a way to control the number of pages no more than P.

输出

For each testcase, output a line with an integer Ans, indicating the maximum font size Steven can set.

样例输入
2
1 10 4 3
10
2 10 4 3
10 10

样例输出
3
2


题目链接:http://hihocoder.com/problemset/problem/1288

题目大意:n段文章,每段文章ai个字,手机尺寸是w*h的,现在要放大字体,字体为s时每行可以显示w/s向下取整个字,每页可以显示h/s向下取整个行,求分页不超过p时字体最大可以为多少。

题目分析:数据很小,直接枚举,算出每次一共要多少行,然后再算要多少页。

#include <cstdio>
#include <algorithm>
#define ll long long
using namespace std;
int const MAX = 1e3 + 5;
ll a[MAX];

int main()
{
int T;
scanf("%d", &T);
while(T --)
{
ll n, p, w, h;
ll sum = 0;
scanf("%lld %lld %lld %lld", &n, &p, &w, &h);
for(int i = 0; i < n; i++)
scanf("%lld", &a[i]);
ll mi = min(w, h);
ll ans = 0, tot, perline, line, perpg, pg;
for(ll i = mi; i >= 1; i--)
{
tot = 0;
perline = w / i;
for(int j = 0; j < n; j++)
{
line = a[j] / perline + (a[j] % perline != 0);
tot += line;
}
perpg = h / i;
pg = tot / perpg + (tot % perpg != 0);
if(pg <= p)
{
ans = i;
break;
}
}
printf("%lld\n", ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: