您的位置:首页 > 其它

1027. Colors in Mars (20)

2016-04-06 22:29 267 查看
1027. Colors in Mars (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input

15 43 71

Sample Output

#123456

#include<iostream>
#include<vector>
#include<string>
using namespace std;
int main()
{
vector<int> vec;
int temp,count=0;
int a[3];
cin>>a[0]>>a[1]>>a[2];
for(int i=2;i>=0;i--)
{
count=0;
temp=a[i];
while(temp)
{
vec.push_back(temp%13);
count++;
temp=temp/13;
}
while(count<2)//判断为0的情况,如果temp是一位,则加一个零,如果temp是零,则要加两个零
{
vec.push_back(0);
count++;
}
}
cout<<"#";
for(int i=vec.size()-1;i>=0;i--)
{
if(vec[i]==10)
cout<<"A";
else if(vec[i]==11)
cout<<"B";
else if(vec[i]==12)
cout<<"C";
else
cout<<vec[i];
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: