您的位置:首页 > 其它

hdu-1078 FatMouse and Cheese

2016-04-05 23:21 302 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1078

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7471    Accepted Submission(s): 3076


[align=left]Problem Description[/align]
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100
blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

 

[align=left]Input[/align]
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.

The input ends with a pair of -1's.

 

[align=left]Output[/align]
For each test case output in a line the single integer giving the number of blocks of cheese collected.

 

[align=left]Sample Input[/align]

3 1
1 2 5
10 11 6
12 12 7
-1 -1

 

[align=left]Sample Output[/align]

37

题意:给定两个变量n和k  在给定一个n*n的矩阵,矩阵的每一个点有一块奶酪,数字代表大小。老鼠从左上角开始走,每次可以往上下左右四个方向走1~k步,但每一次只能往奶酪大小比当前奶酪大的地方走(也就是说走的是递增路径),问最多可以吃到多少奶酪。

思路:给所以奶酪排个序,然后在找的的时候就能保证比当前节点小的奶酪已经是最优解,已经更新过了。  注意flag数组表示左上角能不能到达当前点,不能到达则不能计入更新。

代码:

#include <iostream>

#include <cstdio>

#include <cstring>

#include <algorithm>

using namespace std;

#define N 110

int m

;

int flag

;

int dp

;

struct Node

{

    int num;

    int x,y;

}node[N*N];

bool cmp(Node a,Node b)

{

    return a.num<b.num;

}

int main()

{

    int n,k;

    while(scanf("%d %d",&n,&k)&&n>0&&k>0)

    {

        for(int i=0;i<n;i++)

        {

            for(int j=0;j<n;j++)

            {

                scanf("%d",&m[i][j]);

                node[i*n+j].num=m[i][j];

                node[i*n+j].x=i;

                node[i*n+j].y=j;

            }

        }

        sort(node,node+n*n,cmp);

        memset(dp,0,sizeof(dp));

        memset(flag,0,sizeof(flag));

        dp[0][0]=m[0][0];

        int ans=dp[0][0];

        int maxn;

        for(int i=0;i<n*n;i++)

        {

            int x=node[i].x,y=node[i].y;

            maxn=-1;

            for(int j=1;j<=k;j++)

            {

                if(x-j>=0&&m[x-j][y]<m[x][y]&&!flag[x-j][y]){

                    if(maxn<dp[x-j][y])

                        maxn=dp[x-j][y];

                }

                if(x+j<n&&m[x+j][y]<m[x][y]&&!flag[x+j][y]){

                    if(maxn<dp[x+j][y])

                        maxn=dp[x+j][y];

                }

                if(y-j>=0&&m[x][y-j]<m[x][y]&&!flag[x][y-j]){

                    if(maxn<dp[x][y-j])

                        maxn=dp[x][y-j];

                }

                if(y+j<n&&m[x][y+j]<m[x][y]&&!flag[x][y+j]){

                    if(maxn<dp[x][y+j])

                        maxn=dp[x][y+j];

                }

            }

            if(maxn==-1)

            {

                if(x==0&&y==0)

                continue;

             flag[x][y]=1;

              continue;

            }

            dp[x][y]=max(dp[x][y],maxn+m[x][y]);

            ans=max(ans,dp[x][y]);

        }

        printf("%d\n",ans);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: