您的位置:首页 > 其它

POJ-2151 Check the difficulty of problems

2016-04-03 20:45 316 查看
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 6332Accepted: 2756
Description
Organizing a programming contest is not an easy job. To avoid making the problems too difficult, the organizer usually expect the contest result satisfy the following two terms:

1. All of the teams solve at least one problem.

2. The champion (One of those teams that solve the most problems) solves at least a certain number of problems.

Now the organizer has studied out the contest problems, and through the result of preliminary contest, the organizer can estimate the probability that a certain team can successfully solve a certain problem.

Given the number of contest problems M, the number of teams T, and the number of problems N that the organizer expect the champion solve at least. We also assume that team i solves problem j with the probability Pij (1 <= i <= T, 1<= j <= M). Well, can you
calculate the probability that all of the teams solve at least one problem, and at the same time the champion team solves at least N problems?

Input
The input consists of several test cases. The first line of each test case contains three integers M (0 < M <= 30), T (1 < T <= 1000) and N (0 < N <= M). Each of the following T lines contains M floating-point numbers in the range
of [0,1]. In these T lines, the j-th number in the i-th line is just Pij. A test case of M = T = N = 0 indicates the end of input, and should not be processed.
Output
For each test case, please output the answer in a separate line. The result should be rounded to three digits after the decimal point.
Sample Input
2 2 2
0.9 0.9
1 0.9
0 0 0

Sample Output
0.972

Source
POJ Monthly,鲁小石

分析:概率DP 待补

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
double f[1001][31][31],p[1001][31],s[1001][31];
int m,t,n;
int main()
{
cin.sync_with_stdio(false);
while(cin>>m>>t>>n && m && t && n)
{
for(int i=1;i <= t;i++)
for(int j=1;j <= m;j++)
cin>>p[i][j];
memset(f,0,sizeof(f));
memset(s,0,sizeof(s));
for(int i=1;i <= t;i++)
{
f[i][0][0]=1.0;
for(int j=1;j <= m;j++)
for(int k=0;k <= j;k++)
f[i][j][k]=f[i][j-1][k]*(1.0-p[i][j])+f[i][j-1][k-1]*p[i][j];
for(int k=0;k <= m;k++)
for(int j=0;j <= k;j++)
s[i][k]+=f[i][m][j];
}
double p1=1.0,p2=1.0;
for(int i=1;i <= t;i++) p1*=(1-s[i][0]);
for(int i=1;i <= t;i++) p2*=(s[i][n-1]-s[i][0]);
printf("%.3f\n",p1-p2);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: