您的位置:首页 > Web前端

POJ 3253 Fence Repair

2016-04-03 20:43 309 查看
Fence Repair

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 37154Accepted: 12033
Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤
50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made;
you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will
result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8

Sample Output
34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.

The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into
16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
题意看之前写的贪心里的,一样的题,只是现在使用优先队列解答
#include <cstdio>
#include <queue>
using namespace std;

typedef long long ll;

int n;
int L[20001];

void solve()
{
ll ans = 0;

priority_queue<int, vector<int>, greater<int> > que;  //声明一个从小到大取出数值的优先队列
for (int i = 0; i < n; i++)
que.push(L[i]);
while (que.size() > 1){   //循环到只剩一块木板为止
int l1, l2;     //取出最短的木板和次短的木板
l1 = que.top();
que.pop();
l2 = que.top();
que.pop();

ans += l1 + l2;   //把两块木板合并
que.push(l1 + l2);
}
printf("%lld\n", ans);
}

int main()
{
while (scanf("%d", &n) != EOF){
for (int i = 0; i < n; i++){
scanf("%d", &L[i]);
}
solve();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: