您的位置:首页 > 其它

hdu 【1013】Digital Roots

2016-04-03 15:16 337 查看

Digital Roots

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 66831 Accepted Submission(s): 20880

[/b]

[align=left]Problem Description[/align]
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those
digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

[align=left]Input[/align]
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

[align=left]Output[/align]
For each integer in the input, output its digital root on a separate line of the output.

[align=left]Sample Input[/align]

24
39
0


[align=left]Sample Output[/align]

6
3


[align=left]Source[/align]
Greater New York 2000

[align=left]Recommend[/align]
We have carefully selected several similar problems for you: 1017 1021 1048 1020 1019

//虽然说用字符串也可以,但是题目说了用整数为什么不行呀!!人与人之间的信任呢!!

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;

char s[1005];

int main()
{
int n;
while(scanf("%s", s) != EOF && s[0] != '0')
{
int sum = 0,n;
for(int i = 0; i < strlen(s); i++)
sum += s[i] - '0';
while(sum >= 10)
{
n = sum;
sum = 0;
while(n)
{
sum += n%10;
n /= 10;
}
}
printf("%d\n", sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: