您的位置:首页 > 编程语言 > Java开发

hdu5655 CA Loves Stick JAVA大数

2016-04-02 21:52 543 查看


CA Loves Stick

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)

Total Submission(s): 130 Accepted Submission(s): 53



Problem Description

CA loves to play with sticks.

One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral.

(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
Input

First line contains T denoting
the number of testcases.

T testcases
follow. Each testcase contains four integers a,b,c,d in
a line, denoting the length of sticks.

1≤T≤1000, 0≤a,b,c,d≤263−1

Output

For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).

Sample Input

2
1 1 1 1
1 1 9 2


Sample Output

Yes
No


Source

BestCoder Round #78 (div.2)

如果边里面有0,则直接输出No,因为组不成四边形,如果有一条边的长度大于等于其他三条边的和,则输出No,否则输出Yes,long long都会爆,用double会损失

精度一样不行,还是JAVA大数比较方便

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
public static void main(String [] args) {
Scanner in = new Scanner(System.in);
BigInteger num[] = new BigInteger[4];
int T = in.nextInt();
while (T-->0) {
boolean flag = true;
BigInteger sum = BigInteger.ZERO;
for (int i = 0; i < 4; i++) {
num[i] = in.nextBigInteger();
if (num[i].equals(BigInteger.ZERO)) {
flag = false;
}
sum = sum.add(num[i]);
}
if (!flag) {
System.out.println("No");
continue;
}
for (int i = 0; i < 4; i++) {
if (sum.subtract(num[i]).compareTo(num[i]) <= 0) {
flag = false;
break;
}
}
if (flag) {
System.out.println("Yes");
} else {
System.out.println("No");
}
}
in.close();
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: